Deviant
Data Entry and Verification
for NT and 32-bit Windows
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Overview of Deviant
Deviant has been designed as a quick and easy way of entering and verifying data in a form that can
be opened in Remark Office for marking. You can set up a Template, which is a definition of the
fields that make up a data entry line, and the program will only allow entry of the type of data that
matches the template.
Deviant has three modes:
• Data Entry mode allows you to enter the data in the form specified by the template that
you select;
• Verification mode allows you to re-type the data and the program will check what you type
against the data you entered the first time around, ensuring that the data is correct;
• Full text edit mode is a full text editor that allows you to manipulate the data as though you
were in Word, allowing for cut, copy and paste of selected areas.
You can open and work on multiple files at once and each window can have a different template
and mode selected so that you could, for instance, be entering data in one window and verifying
data in another.
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Options
You can optionally have Deviant beep when you make an error and/or
beep when you reach the right margin. You can set both of these under
the Options menu. These options are global, affecting all windows.

Opening and Saving files
Deviant automatically opens a new blank window on startup. You can also open a new blank
window at any time by choosing New from the File menu or by pressing Ctrl-N. New Deviant
windows are created with the Template set to None and in Data Entry mode.
As you type data, you can save your changes at any time by selecting
Save from the File menu or by pressing Ctrl-S. You would normally
save as a .dev file, which stores the current template as well as the data.
When opening a .dev file at a later date, the program will automatically
change the template to whichever was last used with that file.
Under the File menu, Deviant keeps a memory of the last 6 files used, so
it’s easy to quickly access a file you have recently worked on.
Files are always automatically opened in Data Entry mode. If you are
opening a file in order to verify it, you will need to switch into
Verification mode yourself.
The other option for saving files is as a .asc file, a file type which is recognised by and easily
imported into Remark Office. When you are ready to export your data for Remark Office, you
should select a template whose columns match the columns of the Remark Office template you
want to use (this will probably be, but doesn’t have to be, the template you used for typing the data
in) and then select Save As… from the File menu. Save as a .asc file. Note that any fields defined
as “Skip” fields are not saved when you use the .asc format.
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Creating and Modifying Templates
A Template is a set of field definitions for the data you want to enter. Normally, with test data, this
would comprise the student ID, student name, and an individual field for each of the marks. If you
are intending to import the data into Remark Office then the fields you create should match the
fields in the Remark Office template, although the column headings don’t need to match.
You can bring up the Create/Modify Template screen in one of three ways:
• Selecting Create/Modify Templates from the Templates menu
• Pressing the F12 function key
• Clicking the shortcut button on the toolbar
This will display the following screen:

This screen lists the available templates and allows you to create more, or modify and delete
existing ones. A sample window at the bottom shows you a representation of the fields in the first
46 characters of each template – This window changes as you click or arrow through the list of
templates.
You can create a new template by clicking the New button. You can edit an existing template by
clicking the Modify button, or by double-clicking a template in the list or by pressing Enter once
you have moved to the template that you want to edit.
The representation in the sample window is used throughout the program and displays field names
(if there is sufficient space to display them), as well as the following special characters:
• a < character indicates the last character in a field
• a « character indicates the right margin
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When you create or edit a template, the following screen is displayed:

This screen allows you to give the template a name and assign a Function key hotkey as well as
define the fields that comprise the template.
The dropdown list for hotkeys will only show function keys that are unassigned. If you want to
assign a function key that is already assigned to another template, then edit that template first and
set it’s hotkey to None.

Entering Fields
You can add new fields to your template by clicking the Insert button, which will always insert a
new row above the currently selected row. You can add new rows at the bottom by moving down
to the last row (which will always be blank) and inserting there, or by double-clicking or pressing
Enter on any blank rows you can see at the bottom of the template.
In version 1.0 of Deviant, templates are limited to 100 characters, but there is no limit to the
number of fields – A template could have a single field of 100 characters, or 100 fields of 1
character each.
You can edit fields by highlighting them and either
clicking the Modify button or pressing the Enter
key, or by double-clicking the field you want to
edit.
When individual fields are edited, you will see the
screen at right, which allows you to enter an
optional field name, select a field data type (select
from Alphabetic, Alphanumeric, Numeric or Skip),
a field length and whether the field should auto-fill.
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The Field type allows you to restrict the type of data that can be entered into a field. If you select
“Alphabetic” then you will only be able to enter the characters a-z into the field. If you select
“Numeric” then you will only be able to enter numbers.

The “Skip” Field type
A “Skip” field has a special function. It allows you to space the columns out so that they are not
hard up against each other. As an example, two fields defined as:
Student ID
Student Name

Numeric
Alphanumeric

7 characters
30 characters

would be entered into Deviant hard up against each other and difficult to separate visually, e.g.
1234234F Flintstone
1245323B Rubble
Inserting a 1 or 2 character skip field in between allows you to separate the two visually:
1234234 F Flintstone
1245323 B Rubble
When entering data, Deviant will automatically skip over the field – You don’t need to enter a
space manually to move to the next field. In fact, Deviant will not allow you to type data into a
field that has been defined as a skip field (unless the field has also been defined as an auto-fill
field).
Note that when you save data to a .asc file for export to Remark Office, skip fields are not saved to
the file, so you don’t need to make any special allowance for them in your Remark Office template.

Auto-Fill Fields
The Auto-Fill tick-box allows you to set up fields that are always constant in the data being entered.
Whenever a new line is inserted or added at the bottom, the field is automatically filled based on
the data in the same field in the line above. As you type you can simply tab over the auto-fill field
when you reach it.
You can have Deviant automatically move past an auto-fill field by defining the field as both an
Auto-fill field and a Skip field. When a field is defined as being both, then Deviant will allow you
to enter data in the field but only on the first line of the file. On subsequent lines, the field will be
auto-filled and automatically tabbed over, and you will not be able to edit it as with normal skip
fields. This is intended for constant columns that never change throughout the file.
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Data Entry Mode
Data Entry mode is the recommended mode for entering new data. It is designed for fast entry of
characters with minimal use of special keys and is ideal for touch typists.
Characters are checked against the template as they are entered, and Deviant will not allow you to
enter alphabetic characters into a numeric field or vice versa. Skip fields are automatically skipped
over. When you reach the right margin on the last line, a new line is automatically added below the
current line and the cursor moved to the beginning of it.
When a new file is created or an existing file is opened, Data Entry mode is selected by default. If
you are in a different mode, you can return to Data Entry mode by selecting Data Entry mode
from the Edit menu or by pressing the F7 function key. When changing to Data entry mode, the
cursor is automatically positioned on the first character of the last line, ready to begin or continue
data entry.
The screen for Data Entry mode is shown below:
Select the template by choosing from the
drop-down box, or pressing the assigned
hot key for the template that you want.

The position panel
reports the cursor’s
current position in the
file.

The mode indicator
panel tells you what
mode you are currently
working in.

The error panel reports
error messages,
optionally with a beep.
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The template panel shows a
representation of the currently
selected template, along with field
names and < characters to indicate
the last character of each field.
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You can move around the screen using the arrow keys and other special keys to correct data
previously typed. As well as the arrow keys, you can use the following movement keys:
Tab
Shift-Tab

move to next field
move to previous field

Home
End

move to the beginning of the current line
move to the end of the current line

Page Up
Page Down

move up one page at a time
move down one page at a time

Ctrl-Home
Ctrl-End

move to the first character in the file
move to the last character in the file

You can insert new lines within the data already typed by pressing the Insert key, which will insert
a line above the current cursor position.
You can delete characters by pressing the Backspace key, or an entire field by pressing the Delete
key. Note that these two keys function differently than in other programs you may have used in
that they do not move other characters to the right of the deleted character leftwards. This would
move characters out of line of the fields that they are supposed to be in. The Backspace and Delete
keys effectively replace characters with spaces rather than “delete” them in the conventional sense.
You can delete an entire line by pressing Ctrl-Delete.
While the movement keys described at the top of the page are available in all modes, the insertion
and deletion keys are only available in Data Entry mode.
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Verification mode
Verification mode is designed to allow you to retype the data to verify it. The screen is split into
two windows. The top window contains the data in the current file, but it is initially hidden and
only revealed character by character as you type into the bottom window.
Verification mode is entered by selecting Verification mode from the Edit menu or by pressing
the F8 function key
Having changed into Verification mode, you can jump to a particular line number, to begin
verifying at that point, by pressing Ctrl-J or choosing Jump to Line no… from the Edit menu.
In Verification mode, data that you type into the bottom window is checked against the current
template and also against the original data in the top window. If you type a character that differs
from the original data, Deviant will display an error message and, optionally, beep. It won’t allow
you to continue to the next column until you either type the correct character or, if the original data
is incorrect, correct the original.
There are two ways that you can correct the original data if it is incorrect. You can either:
• press the correct key 3 times (after reporting an error twice, Deviant will accept the
character and change the original data on the third attempt);
• press the F11 function key which will immediately substitute the character in the original
data with the new character just typed, and allow you to continue.

Introduction to Deviant

10

16/06/2003

Full Text Edit mode
Full Text edit mode allows you full editing capabilities on the data, as though you were in Word or
Notepad. You can select areas with the mouse or by holding down the shift key while you move,
and can use cut, copy and paste just as you would in other windows programs. Although the
template is still displayed, it is ignored – there is no validation of the changes that you make.
Full Text edit mode is provided in the event that you make large scale mistakes while entering data,
e.g.
If a specific order is required and you have entered the lines out of order, you can use Full
Text edit mode to cut and paste the lines into the correct order.
Full Text edit mode is entered by selecting Full Text edit mode from the Edit menu or by pressing
the F9 function key
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Movement Key Summary
(Available in all modes)
Key Sequence
Up arrow
Down arrow
Left arrow
Right arrow
PageUp
PageDown
Home
End
Ctrl-Home
Ctrl-End

Function
Up one line
Down one line
Left one character
Right one character
Up one page
Down one page
Beginning of Line
End of Line
Top of File
End of File

Function Key Summary
(Functions available in all modes)
Key Sequence
F1
F2
F3
F4
F5
F6
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Function
The first 6 function keys
can be assigned to your 6
most commonly used
templates as shortcut keys
for selecting the template.

F7
F8
F9

Data Entry mode
Verification mode
Full text edit mode

F12

Create/Modify Templates
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Function Key Summary
(Functions available in certain modes only)
Key Sequence
F11
Ctrl-J

Function
Substitute character
Jump to Line no

Mode
Verification mode only
Verification mode only

Tab

Move to next field

Shift-Tab

Move to previous
field

Data Entry and
Verification modes only
Data Entry and
Verification modes only

Insert
Backspace

Insert new line above
cursor
Delete one character

Delete

Delete entire field

Ctrl-End

Delete entire line

Ctrl-X
Ctrl-C
Ctrl-V
Ctrl-A

Cut
Copy
Paste
Select All
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Data Entry mode only
Data Entry and Full
Text edit modes only
Data Entry and Full
Text edit modes only
Data Entry and Full
Text edit modes only
Full text edit mode only
Full text edit mode only
Full text edit mode only
Full text edit mode only
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